Home | Gallery | Forum | Ads YESTERDAYSTRUCK.COM 
The Classic Truck Resource Page
Vintage Truck Headquarters

 
Featured Photo


Marketplace
Classified Ads
Photo Ads

Community
Discussion Forum
Forum Archives

Galleries
Misc Truck Photos
Ford Truck Photos
Picture List

Research & Info
Model Profiles
Ford F-Series
Truck Links

Miscellaneous
Contact Us

Related Sites
Antique Tractors
Kountry Life
Tractor Parts
Tractor Manuals

[Home]
Discussion Forum

!969 F-250 Starting Problem

Welcome [Log out]
Author 
JPM in WA

05-21-2007 07:03:07




Report to Moderator

Originally I had a problem with the battery losing its charge over aprox. a two week period. I could charge the battery and then run it for another two weeks or so. Well, I tired of that and decided to "fix" it. I can't remember my reasoning, but I decided to replace the starting motor relay. Bad idea? or Bad part? Ever since I did that the truck won't start and the battery sparks at the pos. side when the ignition is turned. I have a charging system wiring diagram, but other than that I am pretty clueless about this vehicle. Can someone give me some advice. The more details the better. Thanks.

[Reply]   [No Email]
Bob

05-21-2007 07:19:29




Report to Moderator
 Re: !969 F-250 Starting Problem in reply to JPM in WA , 05-21-2007 07:03:07  
You may have goten a bad relay, or simply connected to two little wires to the wrong terminals.



[Reply]  [No Email]
Billy

05-21-2007 16:24:33




Report to Moderator
 Re: Re: !969 F-250 Starting Problem in reply to Bob, 05-21-2007 07:19:29  
if you're getting sparks at the pos. battery cable, sounds like a loose or dirty connection or bad cable..



[Reply]  [No Email]
[Options]  [Printer Friendly]  [Posting Help]  [Return to Forum]   [Add a Reply]

Hop to:


[Home]

Copyright © 2002-2013 YesterdaysTruck.com
Antique Truck Headquarters