Home | Gallery | Forum | Ads YESTERDAYSTRUCK.COM 
The Classic Truck Resource Page
Vintage Truck Headquarters

 
Featured Photo


Marketplace
Classified Ads
Photo Ads

Community
Discussion Forum
Forum Archives

Galleries
Misc Truck Photos
Ford Truck Photos
Picture List

Research & Info
Model Profiles
Ford F-Series
Truck Links

Miscellaneous
Contact Us

Related Sites
Antique Tractors
Kountry Life
Tractor Parts
Tractor Manuals

[Home]
Classic Truck Discussion Forum

Cussing out my 1990 Chevy K1500

Welcome [Log out]
Author  [Modern View]
wsmm

05-14-2018 18:21:19




Report to Moderator

Replaced the indicator light switch in the front axle, so I could tell when the axle engaged. Then ordered and installed the 4x4 axle actuator from the thermal type to the motor type. Installed the actuator and new wiring harness. Engaged and disengaged the axle twice all was good. Lowered the truck ff of the jack stand and ramp and backed it out of the pole barn. Tried 4 wheel drive again, it would not engage the front axle. Back up on the ramp and jack up and put the jack stand on the passenger to free the tire from the ground.. Engaged the transfer case into 4 high, axle failed to go into 4 wheel drive. Guess I start trouble shooting it tomorrow. Hope it is something simple, don"t really want to go back to the thermal actuator. Any one else have this problem?

[Reply]   [No Email]
mnscruff

05-14-2018 19:38:13




Report to Moderator
 Re: Cussing out my 1990 Chevy K1500 in reply to wsmm, 05-14-2018 18:21:19  
check your ground wire



[Reply]  [No Email]
[Options]  [Printer Friendly]  [Posting Help]  [Return to Forum]   [Add a Reply]

Hop to:


[Home]

Copyright © 2002-2013 YesterdaysTruck.com
Antique Truck Headquarters