Home | Gallery | Forum | Ads YESTERDAYSTRUCK.COM 
The Classic Truck Resource Page
Vintage Truck Headquarters

 
Featured Photo


Marketplace
Classified Ads
Photo Ads

Community
Discussion Forum
Forum Archives

Galleries
Misc Truck Photos
Ford Truck Photos
Picture List

Research & Info
Model Profiles
Ford F-Series
Truck Links

Miscellaneous
Contact Us

Related Sites
Antique Tractors
Kountry Life
Tractor Parts
Tractor Manuals

[Home]
Classic Truck Discussion Forum

O/t 1990 Chevy K1500 no fuel supply update

Welcome [Log out]
Author  [Modern View]
wsmm

02-04-2019 05:52:17




Report to Moderator


My plow truck has decided not to run! Turning the ignition on the fuel pump does not run. Going to the run position and holding it for awhile the fuel pump still does not run. Squirting starting fluid into the throttle body the truck starts and runs until the starting fluid is used up. Tested the fuel pump relay and the fuel pump relay socket as follows:

Just got done testing my fuel pump relay off of the truck using a multi-meter and a 9 volt battery. It works fine, so I think I have a problem in the wiring or some other sensor or switch. I tested the fuel pump connector with the key on and the key off with a power probe and got the following results,
Key Off socket A 12 v pos Socket C open, Socket F open, socket E ground, socket D Ground.
Key ON socket A 12 v pos, socket C open, socket F, E, D ground
socket diagram __ ____ __ F E D ___ ___ A C

Is it possible and okay to run power to the ADL , then start and run the plow truck that way. I know I'm passing the low or no oil pressure safety that way but need to have the truck running to plow with.

Also does anyone have any idea of what to check next, I'm about of ideas.

Thanks,
Bill

[Reply]   [No Email]
[Options]  [Printer Friendly]  [Posting Help]  [Return to Forum]   [Add a Reply]

Hop to:


[Home]

Copyright © 2002-2013 YesterdaysTruck.com
Antique Truck Headquarters