Home | Gallery | Forum | Ads YESTERDAYSTRUCK.COM 
The Classic Truck Resource Page
Vintage Truck Headquarters

 
Featured Photo


Marketplace
Classified Ads
Photo Ads

Community
Discussion Forum
Forum Archives

Galleries
Misc Truck Photos
Ford Truck Photos
Picture List

Research & Info
Model Profiles
Ford F-Series
Truck Links

Miscellaneous
Contact Us

Related Sites
Antique Tractors
Kountry Life
Tractor Parts
Tractor Manuals

[Home]
Classic Truck Discussion Board

How to remove PTO pump?


[ Expand ] [ View Follow Ups ] [ Post Followup ] [ Return to Forum ]

Posted by G. L. Grumpy on July 14, 2005 at 22:24:55 from (4.252.224.31):

Have Allison trans, Chelsea pto and an hydraulic pump on it, with adapter between them. I removed the two bolts on pto mount, got it to loosen and turn, won't come off. I then removed the four allen bolts for the adapter, it's loose/turns, but won't come off. The shaft looks one peice between these units, what I can see of it. I can feel a key on it, but not sure why, nothing there I don't think. I've even "popped" it a few times with a hammer to see if it would knock off, but no go! Is there a connector I am missing? Just rusty splines or such? I have PB Blaster soaking on it now. Anyone have install in structions that may show a diagram of it?


Follow Ups:




Post A Followup

Name:
E-Mail:

Subject: Re: How to remove PTO pump?

Comments:

Optional Link URL:
Link Title:
Optional Image URL:

Email Notification: If you check this box, email will be sent to you whenever someone replies to this message. Your email address must be entered above to receive notification. This notification will be cancelled automatically after 2 weeks.


[Home]

Copyright © 2002-2020 YesterdaysTruck.com
Antique Truck Headquarters