Home | Gallery | Forum | Ads YESTERDAYSTRUCK.COM 
The Classic Truck Resource Page
Vintage Truck Headquarters

 
Featured Photo


Marketplace
Classified Ads
Photo Ads

Community
Discussion Forum
Forum Archives

Galleries
Misc Truck Photos
Ford Truck Photos
Picture List

Research & Info
Model Profiles
Ford F-Series
Truck Links

Miscellaneous
Contact Us

Related Sites
Antique Tractors
Kountry Life
Tractor Parts
Tractor Manuals

[Home]
Classic Truck Discussion Board

1967 Mustang 289 2bbl


[ Expand ] [ View Follow Ups ] [ Post Followup ] [ Return to Forum ]

Posted by Andrew on August 12, 2005 at 20:18:13 from (69.11.96.123):

Mom plated her mustang the other day, tonight was the first night we took it out for a drive. On the way home when you come the a light the engine will die and not start. Temp guage was in the middle I have no clue where it normally runs. It doesnt have a fan shroud just a normal 4 blade fan. Would this problem be vapour locking? Im looking into buying a fan shroud. Mom said its always done that but tonight was nice and cool, and as far back as i can remember it never did that. The carb also is wore real bad im thinking it has a effect with it to. you have to pump the snot out of it to get it to start, the choke doesnt work. but when that 289 does run good she goes REAL good that little 8inch rear end has its hands full LOL!


Follow Ups:




Post A Followup

Name:
E-Mail:

Subject: Re: 1967 Mustang 289 2bbl

Comments:

Optional Link URL:
Link Title:
Optional Image URL:

Email Notification: If you check this box, email will be sent to you whenever someone replies to this message. Your email address must be entered above to receive notification. This notification will be cancelled automatically after 2 weeks.


[Home]

Copyright © 2002-2013 YesterdaysTruck.com
Antique Truck Headquarters