Home | Gallery | Forum | Ads YESTERDAYSTRUCK.COM 
The Classic Truck Resource Page
Vintage Truck Headquarters

 
Featured Photo


Marketplace
Classified Ads
Photo Ads

Community
Discussion Forum
Forum Archives

Galleries
Misc Truck Photos
Ford Truck Photos
Picture List

Research & Info
Model Profiles
Ford F-Series
Truck Links

Miscellaneous
Contact Us

Related Sites
Antique Tractors
Kountry Life
Tractor Parts
Tractor Manuals

[Home]

'70 350 c-10 need some help!

[ View Follow Ups ] [ Post Followup ] [ Return to Forum ]

Posted by Chris on October 03, 2002 at 16:21:13 from (64.122.14.24):

Recently my truck has been running really poorly in the morning. It usually stalls several times on the way to work. When I stall, I restart and a lot of nasty black smoke pumps out of my exhaust pipe (this usually pisses everyone off). Then I have to accellerate excessively to burn off more of the black smoke which upsets people as well. By noon it runs perfectly and does till the next morning. I ran it into a shop today and the guy says it could be a bunch of things including an oil leak on the valves (?)but of course he can't be sure unless I pay him $80 for a one hour diagnostic. If anyone has any ideas about what the problem is, let me know. I got on the freeway and ran it fully accellerated for a bit and a bunch of it burned up. It ran a bit better the next day. I had to do the same thing to burn some carbon off the plugs a ways back, but I don't think that is my problem now.

Follow Ups:




Post A Followup

Name:
E-Mail:

Subject: Re: '70 350 c-10 need some help!

Comments:

Optional Link URL:
Link Title:
Optional Image URL:

Email Notification: If you check this box, email will be sent to you whenever someone replies to this message. Your email address must be entered above to receive notification. This notification will be cancelled automatically after 2 weeks.


[Home]

Copyright © 2002-2013 YesterdaysTruck.com
Antique Truck Headquarters